Request for information / help to send characters string via IR

For questions about IRControl, proposals for next releases, ideas for designing page layouts
meziane
Posts: 9
Joined: 06 Jan 2019, 11:40

Request for information / help to send characters string via IR

Post by meziane » 06 Jan 2019, 11:56

Hello,

I have just discovered IR Control and I need information and help for a very specific usage.

Currently I have an Allbot system (robot) which can be managed via Infrared. It uses an Arduino board with a Vrssm shield having the IR receiver. This equipment comes with an IR transmitter to be plug on the audio jack plug of a smartphone. Unfortunately this doesn't run with my smatphone.

I did some search on internet and found Ircontrol. I did some basic check and it appears that Ircontrol sending is recognized by my IR Receiver, unfortunately I don't see how to send specific strings to manage my robot. For example, in order the robot walks forward, I have to send the following string (without quotes):
"<WF 5 10 >\r\n>"

So my question is how can I achieve this as it seems me that with IRControl I can only send a numeric code?

Thatnk in advance for your answer even negative.

Best regards

info@cec.gmbh
Posts: 114
Joined: 25 Jul 2017, 14:27

Re: Request for information / help to send characters string via IR

Post by info@cec.gmbh » 06 Jan 2019, 13:40

Hi Meziane

Just checked forum of Allbot system. They use a proprietary protocol, but I did not found any further information about it. So it seams that the only way is to learn each command with the learning function of IRControl (depending if there is also a IR Receiver in your Infrared Transmitter). If we would have more information about this protocol we could analyze, if there is a way to call the sequence directly by string.

kind regards,
Urs

meziane
Posts: 9
Joined: 06 Jan 2019, 11:40

Re: Request for information / help to send characters string via IR

Post by meziane » 06 Jan 2019, 14:43

Hi Urs,

Thanks a lot for your answer.

I am going to try to contact Velleman to have more information about the protocol they are using. In fa tI cannot use learning function as the transmitter is not usable with my smartphone. From my part, I will continue to explore to see if I found something usable. I will keep you updated.

Best regards

meziane
Posts: 9
Joined: 06 Jan 2019, 11:40

Re: Request for information / help to send characters string via IR

Post by meziane » 07 Jan 2019, 15:20

Hello,
I have just received information from Velleman support. Here after the mail:

=================================================================
Hi Meziane,

We are sending regular UART data at 2400 baud via IR.

The protocol can be reverse engineered by the arduino firmware
but an command look like
<WF 1 200>\r\n
WF is Walk forward
1 is how many steps
200 is the speed
and put it between angle brackets
==================================================================

Velleman sent also to me the link to the file invlved : https://github.com/Velleman/ALLBOTREMOT ... T/Robot.cs

I haven't had yet time to have a close look on this...

Regards

info@cec.gmbh
Posts: 114
Joined: 25 Jul 2017, 14:27

Re: Request for information / help to send characters string via IR

Post by info@cec.gmbh » 07 Jan 2019, 19:23

Hi

I think this will help, but needs some time to understand the protocol it is based on. Give me some days to analyze it.

kind regards,
Urs

meziane
Posts: 9
Joined: 06 Jan 2019, 11:40

Re: Request for information / help to send characters string via IR

Post by meziane » 07 Jan 2019, 20:20

Hi Urs,

Sure I will wait...

Thanks a lot for your help

Regards

info@cec.gmbh
Posts: 114
Joined: 25 Jul 2017, 14:27

Re: Request for information / help to send characters string via IR

Post by info@cec.gmbh » 13 Jan 2019, 15:47

Hi Meziane

Now, we have analyzed the soruce code from Vellman and also defined a protocol to control the Allbot. The transmit the speed is a little a probelm, because the length of the speed string is variable. In a first step we fixed it for a step range from 10 until 90.

When you import the attached file (Menu Datatransfer) you will have an aditional protocol (Allbot) for the configuration of the device. You can configure it as follows:

Device: The Action as ASCII-Code (for example 87 for W)
Subdevice: The Direction as ASCII-Code (for example 70 for F)
Function: Number of steps (1 - 9)
Extra: Speed in steps 10 bis 90 without the "0" ("V=1" for 10)

Please let me know if it works. If it works well, we can see if we find a better solution for the speed an we could support the full range (1 - 250). But this needs a code change in IRControl App.

Kind regards,
Urs
Attachments
AllbotProtocol.zip
(2.42 KiB) Downloaded 23 times

meziane
Posts: 9
Joined: 06 Jan 2019, 11:40

Re: Request for information / help to send characters string via IR

Post by meziane » 13 Jan 2019, 20:57

Hi Urs,

It doesn't work but I think that you are very close to the solution.

You'll find attached parameters I have used (file = screenshot) and the result on the console (raspberry/Arduino Ide console) connected to the robot for debugging purpose. You'll see that all is correctly decoded until function but the reminder of the string is lost.

Tell me If you want I do other tests.

Regards
Attachments
IMG_20190113_204428c.jpg
IMG_20190113_204428c.jpg (387.86 KiB) Viewed 793 times
Screenshot_20190113_204015_ch.cec.ircontrol.jpg
Screenshot_20190113_204015_ch.cec.ircontrol.jpg (252.95 KiB) Viewed 793 times

info@cec.gmbh
Posts: 114
Joined: 25 Jul 2017, 14:27

Re: Request for information / help to send characters string via IR

Post by info@cec.gmbh » 13 Jan 2019, 21:07

Hi Meziane

Oh, sorry - I forgot to write. The send test function does unfortunately not work with an extra parameter. This is a bug in IRControl. We will fix it in the next release. You have to call it from a button in a page design.

kind regards,
Urs

meziane
Posts: 9
Joined: 06 Jan 2019, 11:40

Re: Request for information / help to send characters string via IR

Post by meziane » 13 Jan 2019, 21:29

Hi Urs,

I have just tried after to have created a button and unfortunately the result is the same than explained into my last post.

Best regards

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests